當前位置:首頁 > PHP教程 > php環境安裝 > 列表

phpMyAdmin正確的安裝配置參數詳解

發布:smiling 來源: PHP粉絲網  添加日期:2018-06-13 10:30:07 瀏覽: 評論:0 

1.先到網上下載phpmyadmin,再解壓到可以訪問的web目錄下(如果是虛擬空間,可以解壓后通過ftp等上傳到web目錄下),當然您可以修改解壓后該文件的名稱。

2.配置config文件

打開libraries下的config.default.php文件,依次找到下面各項,按照說明配置即可:

A.訪問網址

$cfg['PmaAbsoluteUri'] = '';這里填寫phpmyadmin的訪問網址

如:$cfg['PmaAbsoluteUri'] = 'http://www.piaoyi.org/phpmyadmin/';

這里因為我是本地調試,我改為$cfg['PmaAbsoluteUri'] = 'http://localhost/phpmyadmin/';

注意:不要漏掉最后的反斜杠/和開頭的http。

B.mysql主機信息

  1. $cfg['Servers'][$i]['host'] = 'localhost'// MySQL hostname or IP address 
  2. 填寫localhost或mysql所在服務器的ip地址,如果mysql和該phpmyadmin在同一服務器,則按默認localhost 
  3. $cfg['Servers'][$i]['port'] = ''// MySQL port - leave blank for default port 

mysql端口,如果是默認3306,保留為空即可

C.mysql用戶名和密碼

  1. $cfg['Servers'][$i]['user'] = 'root'// MySQL user 訪問phpmyadmin使用的mysql用戶名 
  2. fg['Servers'][$i]['password'] = ''// MySQL password (only needed對應上述mysql用戶名的密碼 

D.認證方法

$cfg['Servers'][$i]['auth_type'] = 'cookie';

在此有四種模式可供選擇,cookie,http,HTTP,config

config方式即輸入phpmyadmin的訪問網址即可直接進入,無需輸入用戶名和密碼,是不安全的,不推薦使用。

當該項設置為cookie,http或HTTP時,登錄phpmyadmin需要數據用戶名和密碼進行驗證,具體如下:

PHP安裝模式為Apache,可以使用http和cookie;

PHP安裝模式為CGI,可以使用cookie

我個人建議:無論是本地還是網絡上,都建議設置成cookie,安全第一。

E.短語密碼(blowfish_secret)的設置

$cfg['blowfish_secret'] = '';

如果認證方法設置為cookie,就需要設置短語密碼,置于設置為什么密碼,由您自己決定  ,但是不能留空,否則會在登錄phpmyadmin時提示錯誤

F.設置默認語言與編碼

查找 $cfg['DefaultLang'] = 'zh'; (這里是選擇語言,zh代表簡體中文的意思) 還有 $cfg['DefaultCharset'] = 'gb2312';(修改默認編碼為國標)

好了,到此為止,您已經成功安裝了phpmyadmin,簡單吧 ,趕快登錄體驗下吧

如果要安裝過程中出現:“phpMyAdmin - 錯誤 缺少 mysqli 擴展。請檢查 PHP 配置。”錯誤。

解決方法如下:

①到phpmyadmin文件夾的\libraries\config.default.php文件中找:$cfg['Servers'][$i]['extension']='mysql';語句。

②如果有找到$cfg['Servers'][$i]['extension']='mysql';這句,就繼續查找下面這句$cfg['Servers'][$i]['extension']='mysqli'; 并把其的注釋去掉。

③如果沒有找到$cfg['Servers'][$i]['extension']='mysql';這句,就把$cfg['Servers'][$i]['extension']='mysqli';語句,改成$cfg['Servers'][$i]['extension']='mysql'; 語句。(即確保 " mysql " 值能生效)

phpmyadmin PHP 5.3+ is required問題解決辦法]\

這種情況其實是站長們下載的phpmyadmin軟件版本太新,最低要php5.3.x以上的版本才(www.rserpo.live)能支持,否則低于該版本不會運行,而提示這個錯誤,解決的辦法是下載一個低版本的即可,如php4.0

Tags: phpMyAdmin 安裝配置

分享到:

广西快3最大遗漏值统计表